Поправка: .NET Framework 4.7 не се поддържа от тази операционна система

.Net Framework е инфраструктура за програмиране, въведена от Microsoft. Ще ви трябва .Net Framework, за да стартирате различни приложения и услуги. Повечето приложения, които изискват .Net Framework, са снабдени и с инсталационните му файлове. Така че, той автоматично ще бъде инсталиран във вашата система, когато инсталирате приложение. Но може да видите грешка „.NET Framework 4.7 не се поддържа от тази операционна система“ при инсталиране на приложение. Тази грешка ще ви попречи да инсталирате успешно приложението. Може да видите тази грешка, когато се опитвате да инсталирате .Net Framework като самостоятелно приложение / услуга.

Причината, поради която се появява тази грешка, е същата, както е спомената в съобщението за грешка. Въпреки че .Net Framework се поддържа на Windows 10, но не е съвместим с всички версии на Windows 10. Така че, ако виждате това съобщение, най-вероятната причина за тази грешка е, че използвате версия на Windows 10, която не е съвместим с .Net Framework.

Метод 1: Актуализирайте Windows 10

Единственото решение за този проблем е просто да актуализирате вашия Windows 10. Препоръчително е да проверите за актуализации на Windows, дори ако използвате най-новата версия на Windows 10. Тъй като проблемът е причинен от несъвместима операционна система, инсталирайте всички налични Windows 10 актуализациите най-вероятно ще разрешат проблема. Можете също да проверите точната версия на вашия Windows 10 и версията, изисквана от .Net Framework, като следвате стъпките, дадени по-долу.

  1. Задръжте клавиша Windows и натиснете R
  2. Въведете winver и натиснете Enter

  1. Вашата версия трябва да бъде спомената в новоотворения прозорец. Номерът след Версията (на втория ред) е номерът на вашата версия. Числото трябва да е 1507 или 1709. Първите 2 цифри са годината, а вторите 2 представляват месеца. Така че, ако имате версия 1709, това означава, че използвате версия, издадена на септември 2017 г.

  1. Сега трябва да се уверите, че имате версията на Windows 10, която е съвместима с .Net Framework. Щракнете тук и щракнете върху системните изисквания

Ако погледнете раздела Поддържана операционна система , там пише Windows 10 Anniversary Update и Windows 10 Creators update . Тъй като много хора не са запознати с номерата на версиите, свързани с актуализациите Anniversary и Creators, ние ги споменахме по-долу

  • Актуализация през ноември (1511)
  • Юбилейна актуализация (14393)
  • Актуализация за създатели (1703)
  • Актуализация на есенните създатели (1709)
  • Актуализация за пролетни създатели (1803)

Както можете да видите, Anniversary Update има номер на версия 14393, а Creators Update има версия 1703. Така че, ако имате версия по-ниска от 14393, няма да можете да инсталирате .Net Framework 4.7 на Windows 10. Сега просто актуализирайте Windows и се уверете, че имате най-новата версия на Windows 10 и опитайте отново.